广州linux

当前位置:   网站首页 >> 网络杂谈

H3C交换机配置命令大全

1system-view 进入系统视图模式


2sysname 为设备命名

3displaycurrent-configuration 当前配置情况

4language-mode Chinese|English 中英文切换

5interfaceEthernet 1/0/1 进入以太网端口视图

6 portlink-type Access|Trunk|Hybrid 设置端口访问模式

7 undoshutdown 打开以太网端口

8 shutdown 关闭以太网端口

9 quit 退出当前视图模式

10 vlan 10 创建VLAN 10并进入VLAN 10的视图模式

11 port accessvlan 10 在端口模式下将当前端口加入到vlan10

12port E1/0/2to E1/0/5 VLAN模式下将指定端口加入到当前vlan

13port trunkpermit vlan all 允许所有的vlan通过

H3C路由器

1system-view 进入系统视图模式

2sysname R1 为设备命名为R1

3display iprouting-table 显示当前路由表

4language-mode Chinese|English 中英文切换

5interfaceEthernet 0/0 进入以太网端口视图

6 ip address192.168.1.1 255.255.255.0 配置IP地址和子网掩码

7 undoshutdown 打开以太网端口

8 shutdown 关闭以太网端口

9 quit 退出当前视图模式

10 iproute-static 192.168.2.0 255.255.255.0 192.168.12.2 description To.R2 配置静态路由

11 iproute-static 0.0.0.0 0.0.0.0 192.168.12.2 description To.R2 配置默认的路由

H3C S3100 Switch

H3C S3600 Switch

H3C MSR 20-20 Router


1、调整超级终端的显示字号;

2、捕获超级终端操作命令行,以备日后查对;



3 language-modeChinese|English 中英文切换;

4、复制命令到超级终端命令行, 粘贴到主机;

5、交换机清除配置:<H3C>reset save <H3C>reboot

6、路由器、交换机配置时不能掉电,连通测试前一定要

检查网络的连通性,不要犯最低级的错误。

7192.168.1.1/24等同 192.168.1.1255.255.255.0;在配置交换机和路由器时,192.168.1.1 255.255.255.0 可以写成:

192.168.1.1 24

8、设备命名规则:地名-设备名-系列号例:PingGu-R-S3600


H3C华为交换机端口绑定基本配置2008-01-2213:40

1,端口 MAC

a)AM命令

使用特殊的AMUser-bind命令,来完成MAC地址与端口之间的绑定。例如:

[SwitchA]am user-bind mac-address 00e0-fc22-f8d3 interface Ethernet 0/1

配置说明:由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允许PC1上网,而使用其他未绑定的MAC地址的PC机则无法上网。但

PC1使用该MAC地址可以在其他端口上网。

b)mac-address命令

使用mac-addressstatic命令,来完成MAC地址与端口之间的绑定。例如:

[SwitchA]mac-address static 00e0-fc22-f8d3 interface Ethernet 0/1 vlan 1

[SwitchA]mac-address max-mac-count 0

配置说明:由于使用了端口学习功能,故静态绑定mac后,需再设置该端口mac学习数为0,使其他PC接入此端口后其mac地址无法被学习。

2IP MAC

a)AM命令

使用特殊的AMUser-bind命令,来完成IP地址与MAC地址之间的绑定。例如:

[SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3

配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定,即与绑定的IP地址或者MAC地址不同的PC机,在任何端口都无法上网。

支持型号:S3026E/EF/C/G/TS3026C-PWRE026/E026TS3050CE050S3526E/C/EFS5012T/GS5024G

b)arp命令

使用特殊的arpstatic命令,来完成IP地址与MAC地址之间的绑定。例如:

[SwitchA]arp static 10.1.1.2 00e0-fc22-f8d3

配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定。

3,端口 IP MAC

使用特殊的AMUser-bind命令,来完成IPMAC地址与端口之间的绑定。例如:

[SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3 interfaceEthernet 0/1

配置说明:可以完成将PC1IP地址、MAC地址与端口E0/1之间的绑定功能。由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允

PC1上网,而使用其他未绑定的IP地址、MAC地址的PC机则无法上网。但是PC1使用该IP地址和MAC地址可以在其他端口上网。


[S2016-E1-Ethernet0/1]mac-address max-mac-count 0;

进入到端口,用命令macmax-mac-count 0(端口mac学习数设为0)

[S2016-E1]mac static 0000-9999-8888 int e0/1 vlan 10;

0000-9999-8888绑定到e0/1端口上,此时只有绑定macpc可以通过此口上网,同时E0/1属于vlan 10

就这样,ok了,不过上面两个命令顺序不能弄反,除非端口下没有接pc


dis vlan 显示vlan

name text 指定当前vlan的名称

undo name 取消

[h3c] vlan 2

[h3c-vlan2]name test vlan

dis users 显示用户

dis startup 显示启动配置文件的信息

dis user-interface 显示用户界面的相关信息

dis web users 显示web用户的相关信息。

header login 配置登陆验证是显示信息

header shell

undo header

lock 锁住当前用户界面

acl 访问控制列表 aclnumber inbound/outbound

[h3c]user-interface vty 0 4

[h3c-vty0-4] acl 2000 inbound

shutdown:关闭vlan接口

undo shutdown 打开vlan接口

关闭vlan1 接口

[h3c] interface vlan-interface 1

[h3c-vlan-interface] shutdown

vlan vlan-id 定义vlan

undo valn vlan-id

display ip routing-table

display ip routing-table protocol static

display ip routing-table statistics

display ip routing-table verbose 查看路由表的全部详细信息

interface vlan-interface vlan-id 进入valn

management-vlan vlan-id 定义管理vlan

reset ip routing-table statistics protocol all 清除所有路由协议的路由信息.

display garp statistics interface GigabitEthernet 1/0/1 显示以太网端口上的garp统计信息

display voice vlan status 查看语音vlan状态

[h3c-GigabitEthernet1/0/1] broadcast-suppression 20 允许接受的最大广播流量为该端口传输能力的20%.超出部分丢弃.

[h3c-GigabitEthernet1/0/1] broadcast-suppression pps 1000 每秒允许接受的最大广播数据包为1000传输能力的20%.超出部分丢弃.

display interface GigabitEthernet1/0/1 查看端口信息

display brief interface GigabitEthernet1/0/1 查看端口简要配置信息

display loopback-detection 用来测试环路测试是否开启

display transceiver-information interface GigabitEthernet1/0/50 显示光口相关信息

duplex auto/full/half

[h3c]interface GigabitEthernet1/0/1

[h3c-GigabitEthernet1/0/1]duplux auto 设置端口双工属性为自协商

port link-type access/hybrid/trunk 默认为access

port trunk permit vlan all trunk扣加入所有vlan

reset counters interface GigabitEthernet1/0/1 清楚端口的统计信息

speed auto 10/100/1000

display port-security 查看端口安全配置信息

am user-bind mac-addr 00e0-fc00-5101 ip-addr 10.153.1.2 interfaceGigabitEthernet1/0/1 端口ip绑定

display arp 显示arp

display am user-bind 显示端口绑定的配置信息

display mac-address 显示交换机学习到的mac地址

display stp 显示生成树状态与统计信息

[h3c-GigabitEthernet1/0/1]stp instance 0 cost 200 设置生成树实例0上路径开销为200

stp cost 设置当前端口在指定生成树实例上路径开销。instance-id 0-16 0cist 取值范围1-200000

<h3c> display system-guard ip-record 显示防攻击记录信息.

system-guard enable 启用系统防攻击功能

display icmp statistics icmp流量统计

display ip socket

display ip statistics

display acl all

acl number acl-number match-order auto/config

acl-number (2000-2999 是基本acl 3000-3999是高级acl为管理员预留的编号)

rule deny/permit protocal

访问控制

[h3c] acl number 3000

[h3c-acl-adv-3000]rule permit tcp source 129.9.0.0 0.0.255.255 destination202.38.160.0 0.0.255.255 destination-port eq 80 (

定义高级acl 3000,允许129.0.0/16网段的主机向202.38.160/24网段主机访问端口80)

rule permit source 211.100.255.0 0.255.255.255

rule deny cos 3 souce 00de-bbef-adse ffff-ffff-fff dest 0011-4301-9912ffff-ffff-ffff

(禁止mac地址00de-bbef-adse发送到mac地址0011-4301-9912802.1p优先级为3的报文通过)

display qos-interface GigabitEthernet1/0/1 traffic-limit 查看端口上流量

端口速率限制

line-rate inbound/outbound target-rate

inbound:对端口接收报文进行速率限制

outbound: 对端口发送报文进行速率限制

target-rate 对报文限制速率,单位kbps 千兆口 inbound范围1-1000000 outbound范围20-1000000

undo line-rate取消限速.

[h3c]interface GigabitEthernet1/0/1

[h3c-GigabitEthernet1/0/1]line-rate outbound 128 限制出去速率为128kbps

display arp | include 77

display arp count 计算arp表的记录数

display ndp 显示交换机端口的详细配置信息。

display ntdp device-list verbose 收集设备详细信息

display lock

display users

display cpu

display memory

display fan

display device

display power

华为交换机常用配置实例

sys 进入到系统视图
Enter system view, return to user view with Ctrl+Z.

[Quidway]user-interface aux 0
[Quidway-ui-aux0]authentication-mode scheme
Notice: Telnet or SSH user must be added , otherwise operator can't login!
[Quidway-ui-aux0]qu

[Quidway]local-user huawei 增加用户名
New local user added.
[Quidway-luser-huawei]password simple huawei 配置密码,且密码不加密
[Quidway-luser-huawei]service-type telnet ssh level 3
服务类型为SSHtelnet,且用户登陆后权限为管理员权限
[Quidway-luser-huawei]qu
[Quidway]user-interface vty 0 4
[Quidway-ui-vty0-4]authentication-mode scheme
Notice: Telnet or SSH user must be added , otherwise operator can't login!
[Quidway-ui-vty0-4]

<Quidway>save

华为QuidWay交换机配置命令手册:
1、开始
建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。
在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100
以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如<Quidway>)。
键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入"?"
2、命令视图
(1)用户视图(查看交换机的简单运行状态和统计信息)<Quidway>:与交换机建立连接即进入
(2)系统视图(配置系统参数)[Quidway]:在用户视图下键入system-view
(3)以太网端口视图(配置以太网端口参数)[Quidway-Ethernet0/1]:在系统视图下键入interface ethernet 0/1
(4)VLAN视图(配置VLAN参数)[Quidway-Vlan1]:在系统视图下键入vlan 1
(5)VLAN接口视图(配置VLANVLAN汇聚对应的IP接口参数)[Quidway-Vlan-interface1]:在系统视图下键入interface vlan-interface 1
(6)本地用户视图(配置本地用户参数)[Quidway-luser-user1]:在系统视图下键入local-user user1
(7)用户界面视图(配置用户界面参数)[Quidway-ui0]:在系统视图下键入user-interface
3、其他命令
设置系统时间和时区<Quidway>clocktime Beijing  add 8
                 <Quidway>clock datetime 12:00:00 2005/01/23
设置交换机的名称[Quidway]sysnameTRAIN-3026-1[TRAIN-3026-1]
配置用户登录[Quidway]user-interfacevty 0 4
            [Quidway-ui-vty0]authentication-modescheme
创建本地用户[Quidway]local-userhuawei
            [Quidway-luser-huawei]password simplehuawei
            [Quidway-luser-huawei] service-typetelnet level 3
4VLAN配置方法
『配置环境参数』
SwitchA端口E0/1属于VLAN2E0/2属于VLAN3
『组网需求』
把交换机端口E0/1加入到VLAN2 E0/2加入到VLAN3
数据配置步骤
VLAN配置流程』
(1)缺省情况下所有端口都属于VLAN1,并且端口是access端口,一个access端口只能属于一个vlan
(2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉;
(3)除了VLAN1,如果VLAN XX不存在,在系统视图下键入VLAN XX,则创建VLAN XX并进入VLAN视图;如果VLAN XX已经存在,则进入VLAN视图。
SwitchA相关配置】
方法一:
(1)创建(进入)vlan2
  [SwitchA]vlan 2
(2)将端口E0/1加入到vlan2
  [SwitchA-vlan2]port ethernet 0/1
(3)创建(进入)vlan3
  [SwitchA-vlan2]vlan 3
(4)将端口E0/2加入到vlan3
  [SwitchA-vlan3]port ethernet 0/2
方法二:
(1)创建(进入)vlan2
  [SwitchA]vlan 2
(2)进入端口E0/1视图
  [SwitchA]interface ethernet 0/1
(3)指定端口E0/1属于vlan2
  [SwitchA-Ethernet1]port access vlan 2
(4)创建(进入)vlan3
  [SwitchA]vlan 3
(5)进入端口E0/2视图
  [SwitchA]interface ethernet 0/2
(6)指定端口E0/2属于vlan3
  [SwitchA-Ethernet2]port access vlan 3
测试验证
(1)使用命令disp cur可以看到端口E0/1属于vlan2E0/2属于vlan3
(2)使用displayinterface Ethernet 0/1可以看到端口为access端口,PVID2
(3)使用displayinterface Ethernet 0/2可以看到端口为access端口,PVID3
5、交换机IP地址配置
功能需求及组网说明
『配置环境参数』
三层交换机SwitchA有两个端口ethetnet 0/1ethernet 0/2,分别属于vlan 2vlan 3
vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的网关;
vlan 3的三层接口地址分别是2.0.0.1/24作为PC2的网关;
『组网需求』
PC1PC2通过三层接口互通
SwitchA相关配置】
(1)创建(进入)vlan2
  [Quidway]vlan 2
(2)将端口E0/1加入到vlan2
  [Quidway-vlan2]port ethernet 0/1
(3)进入vlan2的虚接口
  [Quidway-vlan2]interface vlan 2
(4)vlan2的虚接口上配置IP地址
  [Quidway-Vlan-interface2]ip address 1.0.0.1 255.255.255.0
(5)创建(进入)vlan3
  [Quidway]vlan 3
(6)E0/2加入到vlan3
  [Quidway-vlan3]port ethernet 0/2
(7)进入vlan3的虚接口
  [Quidway-vlan3]interface vlan 3
(8)vlan3的虚接口上配置IP地址
  [Quidway-Vlan-interface3]ip address 2.0.0.1 255.255.255.0
测试验证
(1)PC1PC2都可以PING通自己的网关
(2)PC1PC2可以相互PING
6、端口的trunk配置
『配置环境参数』
(1)SwitchA 端口E0/1属于vlan10E0/2属于vlan20E0/3SwitchB端口E0/3互连
(2)SwitchB 端口E0/1属于vlan10E0/2属于vlan20E0/3SwitchA端口E0/3互连
『组网需求』
(1)要求SwitchAvlan10PCSwitchBvlan10PC互通
(2)要求SwitchAvlan20PCSwitchBvlan20PC互通
数据配置步骤
SwitchA相关配置】
(1)创建(进入)vlan10
  [SwitchA] vlan 10
(2)E0/1加入到vlan10
  [SwitchA-vlan10]port Ethernet 0/1
(3)创建(进入)vlan20
  [SwitchA]vlan 20
(4)E0/2加入到vlan20
  [SwitchA-vlan20]port Ethernet 0/2
(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传
  [SwitchA-Ethernet0/3]port link-type trunk
(6)允许所有的vlanE0/3端口透传通过,也可以指定具体的vlan
  [SwitchA-Ethernet0/3]port trunk permit vlan all
SwitchB相关配置】
(1)创建(进入)vlan10
  [SwitchB] vlan 10
(2)E0/1加入到vlan10
  [SwitchB-vlan10]port Ethernet 0/1
(3)创建(进入)vlan20
  [SwitchB]vlan 20
(4)E0/2加入到vlan20
  [SwitchB-vlan20]port Ethernet 0/2
(5)实际当中一般将上行端口设置成trunk属性,允许vlan透传
  [SwitchB-Ethernet0/3]port link-type trunk
(7)允许所有的vlanE0/3端口透传通过,也可以指定具体的vlan
  [SwitchB-Ethernet0/3]port trunk permit vlan all
【补充说明】
(1)如果一个端口是trunk端口,则该端口可以属于多个vlan
(2)缺省情况下trunk端口的PVID1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改端口的PVID
(3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。
(4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。
(5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。
测试验证
(1)SwitchA vlan10内的PC可以与SwitchB vlan10内的PC互通
(2)SwitchA vlan20内的PC可以与SwitchB vlan20内的PC互通
(3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通
(4)SwitchA vlan20内的PC不能与SwitchB vlan10内的PC互通
7、端口汇聚配置
『配置环境参数』
(1)交换机SwitchASwitchB通过以太网口实现互连。
(2)SwitchA用于互连的端口为e0/1e0/2SwitchB用于互连的端口为e0/1e0/2
『组网需求』
增加SwitchASwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚
数据配置步骤
SwitchA交换机配置】
(1)进入端口E0/1
  [SwitchA]interface Ethernet 0/1
(2)汇聚端口必须工作在全双工模式
  [SwitchA-Ethernet0/1]duplex full
(3)汇聚的端口速率要求相同,但不能是自适应
  [SwitchA-Ethernet0/1]speed 100
(4)进入端口E0/2
  [SwitchA]interface Ethernet 0/2
(5)汇聚端口必须工作在全双工模式
  [SwitchA-Ethernet0/2]duplex full
(6)汇聚的端口速率要求相同,但不能是自适应
  [SwitchA-Ethernet0/2]speed 100
(7)根据源和目的MAC进行端口选择汇聚
  [SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both
SwitchB交换机配置】
[SwitchB]interface Ethernet 0/1
[SwitchB-Ethernet0/1]duplex full
[SwitchB-Ethernet0/1]speed 100
[SwitchB]interface Ethernet 0/2
[SwitchB-Ethernet0/2]duplex full
[SwitchB-Ethernet0/2]speed 100
[SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both
【补充说明】
(1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。
(2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。
8、端口镜像配置
『环境配置参数』
(1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24
(2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24
(3)E0/24为交换机上行端口
(4)Server接在交换机E0/8端口,该端口作为镜像端口
『组网需求』
(1)通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。
根据Quidway交换机不同型号,镜像有不同方式进行配置:
基于端口的镜像 ——基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。
基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。
S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像
8016交换机支持基于端口的镜像
3500/3026E/3026F/3050支持基于流的镜像
5516/6506/6503/6506R支持对入端口流量进行镜像
数据配置步骤
QuidwayS3026C为例,通过基于二层流的镜像进行配置:
(1)定义一个ACL
  [SwitchA]acl num 200
(2)定义一个规则从E0/1发送至其它所有端口的数据包
  [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interfaceEthernet0/2
(3)定义一个规则从其它所有端口到E0/1端口的数据包
  [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interfaceEthernet0/1
(4)将符合上述ACL的数据包镜像到E0/8
  [SwitchA]mirrored-to link-group 200 interface e0/8
9、生成树STP配置
『配置环境参数』
(1)交换机SwitchASwitchBSwitchC都通过GE接口互连
(2)SwitchBSwitchC交换机是核心交换机,要求主备。
『组网需求』
要求整个网络运行STP协议
数据配置步骤
(1)SwitchA交换机配置】
  启动生成树协议:[SwitchA]stp enable
(1)SwitchB交换机配置】
  启动生成树协议:[SwitchB]stpenable
(3)配置本桥为根桥
  [SwitchB]stp root primary
(4)SwitchC交换机配置】
  a 启动生成树协议[SwitchC]stpenable
  b 配置本桥为备份根桥[SwitchC]stproot secondary
(5)SwitchD交换机配置】
  a 启动生成树协议[SwitchD]stpenable
【补充说明】
(1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优先级来实现;
(2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式;
(3)如果要控制某条链路的状态可以通过设置端口的cost值来实现。
测试验证
(1)使用display stp查看交换机STP运行状态
(2)查看端口STP状态display stp interface Ethernet XX是否正确
10Quidway交换机维护
显示系统版本信息:displayversion
显示诊断信息:displaydiagnostic-information
显示系统当前配置:displaycurrent-configuration
显示系统保存配置:display saved-configuration
显示接口信息:displayinterface
显示路由信息:displayip routing-table
显示VLAN信息:display vlan
显示生成树信息:displaystp
显示MAC地址表:display mac-address
显示ARP表信息:display arp
显示系统CPU使用率:display cpu
显示系统内存使用率:displaymemory
显示系统日志:displaylog
显示系统时钟:displayclock
验证配置正确后,使用保存配置命令:save
删除某条命令,一般使用命令:undo


 

这里使用的H3C交换机是H126A,仅仅只做了最基本的配置以满足使用。
 
 配置中可以通过display current-configura命令来显示当前使用的配置内容。
 
 # 配置VLAN 1
 <Sysname>system-view
 System View: return to User View with Ctrl+Z.
 [Sysname]vlan 1
 [Sysname-vlan1] quit
 [Sysname]management-vlan 1
 [Sysname]interface Vlan-interface 1
 [Sysname-Vlan-interface1] ip address 10.0.1.201 255.255.255.0
 
 # 显示VLAN 接口1 的相关信息。
 <Sysname> display ip interface Vlan-interface 1
 
 # 创建VLAN(H3C不支持cisco的VTP,所以只能添加静态VLAN)
 <H3C_TEST>system-view
 System View: return to User View with Ctrl+Z.
 [H3C_TEST]vlan 99
 [H3C_TEST-vlan99]name seicoffice
 [H3C_TEST-vlan99]quit
 
 # 把交换机的端端口划分到相应的Vlan中
 [H3C_TEST]interface ethernet1/0/2       //进入端口模式
 [H3C_TEST-Ethernet1/0/2]port link-type access //设置端口的类型为access
 [H3C_TEST-Ethernet1/0/2]port access vlan 99  //把当前端口划到vlan 99
 
 [H3C_TEST]vlan 99
 [H3C_TEST-vlan99]port ethernet1/0/1 to ethernet1/0/24  //把以及网端口1/0/1到1/0/24划到vlan99
 [H3C_TEST-vlan99]quit
 
 [H3C_TEST-GigabitEthernet1/2/1]port trunk permit vlan 1 99     // {ID|All} 设置trunk端口允许通过的VLAN
 -------------------------------------------------------------------------------------------------------
 # 配置本地用户
 <Sysname>system-view
 System View: return to User View with Ctrl+Z.
 [Sysname]local-user h3c
 New local user added.
 [Sysname-luser-h3c]service-type telnet level 3
 [Sysname-luser-h3c]password simple h3c
 
 # 配置欢迎信息
 [H3C_TEST]header login %Welcome to login h3c!%
 
 # 配置用户认证方式telnet(vty 0-4)
 [H3C_TEST]user-interface vty 0 4
 [H3C_TEST-ui-vty0-4]authentication-mode scheme
 [H3C_TEST-ui-vty0-4]protocol inbound telnet
 [H3C_TEST-ui-vty0-4]super authentication-mode super-password
 [H3C_TEST-ui-vty0-4]quit
 [H3C_TEST]super password level 3 simple h3c    //用户登陆后提升权限的密码
 
 # 配置Radius策略
 [H3C_TEST]radius scheme radius1
 New Radius scheme
 [H3C_TEST-radius-radius1]primary authentication 10.0.1.253 1645
 [H3C_TEST-radius-radius1]primary accounting 10.0.1.253 1646
 [H3C_TEST-radius-radius1]secondary authentication 127.0.0.1 1645
 [H3C_TEST-radius-radius1]secondary accounting 127.0.0.1 1646
 
 [H3C_TEST-radius-radius1]timer 5
 [H3C_TEST-radius-radius1]key authentication h3c
 [H3C_TEST-radius-radius1]key accounting h3c
 [H3C_TEST-radius-radius1]server-type extended
 
 
 [H3C_TEST-radius-radius1]user-name-format without-domain
 
 # 配置域
 [H3C_TEST]domain h3c
 [H3C_TEST-isp-h3c]authentication radius-scheme radius1 local
 [H3C_TEST-isp-h3c]scheme radius-scheme radius1 local
 [H3C_TEST]domain default enable h3c
 
 # 配置在远程认证失败时,本地认证的key
 [H3C_TEST]local-server nas-ip 127.0.0.1 key h3c

 

 

 

 

 

 

 

 

 

H3C交换机路由器telnet和console口登录配置

2009年11月09日 星期一 10:00

级别说明
 Level 名称
 命令
 
 0
 参观
 ping、tracert、telnet
 
 1
 监控
 display、debugging
 
 2
 配置
 所有配置命令(管理级的命令除外)
 
 3
 管理
 文件系统命令、FTP命令、TFTP命令、XMODEM命令
 
 
 
 
 
 
 telnet仅用密码登录,管理员权限
 [Router]user-interface vty 0 4[Router-ui-vty0-4]user privilege level  3[Router-ui-vty0-4]set authentication password simple abc
 telnet仅用密码登录,非管理员权限
 [Router]super password level 3 simple super
 [Router]user-interface vty 0 4[Router-ui-vty0-4]user privilege level  1[Router-ui-vty0-4]set authentication password simple abc
 telnet使用路由器上配置的用户名密码登录,管理员权限
 [Router]local-user admin password simple admin[Router]local-user admin  service-type telnet[Router]local-user admin level 3
 [Router]user-interface vty 0 4[Router-ui-vty0-4]authentication-mode local
 telnet使用路由器上配置的用户名密码登录,非管理员权限
 [Router]super password level 3 simple super
 [Router]local-user manage password simple manage[Router]local-user manage  service-type telnet[Router]local-user manage level 2
 [Router]user-interface vty 0 4[Router-ui-vty0-4]authentication-mode local
 对console口设置密码,登录后使用管理员权限
 [Router]user-interface con 0[Router-ui-console0]user privilege level  3[Router-ui-console0]set authentication password simple abc
 对console口设置密码,登录后使用非管理员权限
 [Router]super password level 3 simple super
 [Router]user-interface con 0[Router-ui-console0]user privilege level  1[Router-ui-console0]set authentication password simple abc
 对console口设置用户名和密码,登录后使用管理员权限
 [Router]local-user admin password simple admin[Router]local-user admin  service-type terminal[Router]local-user admin level 3
 [Router]user-interface con 0[Router-ui-console0]authentication-mode local
 对console口设置用户名和密码,登录后使用非管理员权限
 [Router]super password level 3 simple super
 [Router]local-user manage password simple manage[Router]local-user manage  service-type terminal[Router]local-user manage level 2
 [Router]user-interface con 0[Router-ui-console0]authentication-mode local
 
 simple 是明文显示,cipher 是加密显示
 路由器不设置telnet登录配置时,用户无法通过telnet登录到路由器上
 [Router-ui-vty0-4]acl 2000 inbound可以通过acl的规则只允许符合条件的用户远程登录路由器

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

路由器命令
~~~~~~~~~~
[Quidway]display version                         
显示版本信息
[Quidway]display current-configuration           
显示当前配置
[Quidway]display interfaces                      
显示接口信息
[Quidway]display ip route                       
显示路由信息

[Quidway]sysname aabbcc                          
更改主机名
[Quidway]super passwrod 123456                   
设置口令  
[Quidway]interface serial0                       
进入接口
[Quidway-serial0]ip address <ip><mask>
[Quidway-serial0]undo shutdown                   
激活端口
[Quidway]link-protocol hdlc                      
绑定hdlc协议
[Quidway]user-interface vty 0 4
[Quidway-ui-vty0-4]authentication-mode password
[Quidway-ui-vty0-4]set authentication-mode password simple 222
[Quidway-ui-vty0-4]user privilege level 3
[Quidway-ui-vty0-4]quit

[Quidway]debugging hdlc all serial0              
显示所有信息
[Quidway]debugging hdlc event serial0           
调试事件信息
[Quidway]debugging hdlc packet serial0           
显示包的信息

静态路由:
[Quidway]ip route-static <ip><mask>{interfacenumber|nexthop}[value][reject|blackhole]
例如:
[Quidway]ip route-static 129.1.0.0 16 10.0.0.2
[Quidway]ip route-static 129.1.0.0 255.255.0.0 10.0.0.2
[Quidway]ip route-static 129.1.0.0 16 Serial 2
[Quidway]ip route-static 0.0.0.0 0.0.0.0  10.0.0.2


动态路由:
[Quidway]rip
[Quidway]rip work
[Quidway]rip input
[Quidway]rip output
[Quidway-rip]network 1.0.0.0                      ;
可以all
[Quidway-rip]network 2.0.0.0
[Quidway-rip]peer ip-address
[Quidway-rip]summary
[Quidway]rip version 1
[Quidway]rip version 2 multicast
[Quidway-Ethernet0]rip split-horizon            ;
水平分隔

[Quidway]router id A.B.C.D                      
配置路由器的ID
[Quidway]ospf enable                           
启动OSPF协议
[Quidway-ospf]import-route direct              
引入直联路由
[Quidway-Serial0]ospf enable area <area_id>      
配置OSPF区域


标准访问列表命令格式如下:
acl <acl-number> [match-order config|auto]      
默认前者顺序匹配。
rule [normal|special]{permit|deny} [source source-addr source-wildcard|any]
例:
[Quidway]acl 10
[Quidway-acl-10]rule normal permit source 10.0.0.0 0.0.0.255
[Quidway-acl-10]rule normal deny source any


扩展访问控制列表配置命令

配置TCP/UDP协议的扩展访问列表:
rule {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination <ip wild>|any}
[operate]

配置ICMP协议的扩展访问列表:
rule {normal|special}{permit|deny}icmp source {<ip wild>|any]destination{<ip wild>|any]
[icmp-code] [logging]

扩展访问控制列表操作符的含义
equal portnumber             
等于
greater-than portnumber      
大于
less-than portnumber             
小于
not-equal portnumber             
不等
range portnumber1 portnumber2
区间

扩展访问控制列表举例
[Quidway]acl 101
[Quidway-acl-101]rule deny souce any destination any
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo
[Quidway-acl-101]rule permit icmp source any destination any icmp-typeecho-reply

[Quidway]acl 102
[Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.10.0.0.0
[Quidway-acl-102]rule deny ip source any destination any

[Quidway]acl 103
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0destination-port equal ftp
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.2 0.0.0.0destination-port equal www


[Quidway]firewall enable
[Quidway]firewall default permit|deny
[Quidway]int e0
[Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound


地址转换配置举例
[Quidway]firewall enable
[Quidway]firewall default permit
[Quidway]acl 101
[Quidway-acl-101]rule deny ip source any destination any
[Quidway-acl-101]rule permit ip source 129.38.1.4 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.1 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.2 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.3 0 destination any
[Quidway]acl 102
[Quidway-acl-102]rule permit tcp source 202.39.2.3 0 destination 202.38.160.1 0
[Quidway-acl-102]rule permit tcp source any destination 202.38.160.1 0destination-port great-than
1024

[Quidway-Ethernet0]firewall packet-filter 101 inbound
[Quidway-Serial0]firewall packet-filter 102 inbound

[Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1
[Quidway]acl 1
[Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255
[Quidway-acl-1]rule deny source any
[Quidway-acl-1]int serial 0
[Quidway-Serial0]nat outbound 1 address-group pool1

[Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp
[Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp
[Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 wwwtcp
[Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp


PPP
验证:
主验方:pap|chap
[Quidway]local-user u2 password {simple|cipher} aaa
[Quidway]interface serial 0
[Quidway-serial0]ppp authentication-mode {pap|chap}
[Quidway-serial0]ppp chap user u1        //pap
时,不用此句

pap
被验方:
[Quidway]interface serial 0
[Quidway-serial0]ppp pap local-user u2 password {simple|cipher} aaa

chap
被验方:
[Quidway]interface serial 0
[Quidway-serial0]ppp chap user u1        
[Quidway-serial0]local-user u2 password {simple|cipher} aaa


发表我的评论

Hi,您需要填写昵称和邮箱!

  • 必填项